Καλή προσέγγιση

Γρίφοι, Σπαζοκεφαλιές, προβλήματα λογικής, μαθηματικά παιχνίδια, αινίγματα

Συντονιστής: Γιώργος Ρίζος

Άβαταρ μέλους
KARKAR
Δημοσιεύσεις: 11544
Εγγραφή: Τετ Δεκ 08, 2010 6:18 pm

Καλή προσέγγιση

#1

Μη αναγνωσμένη δημοσίευση από KARKAR » Πέμ Νοέμ 14, 2019 11:30 am

Δείξτε ότι η εξίσωση x+lnx=e^2 , έχει μια ρίζα r ,

της οποίας μια πολύ καλή προσέγγιση είναι : r\simeq 2^{2.5}.



Λέξεις Κλειδιά:
Άβαταρ μέλους
Ratio
Δημοσιεύσεις: 245
Εγγραφή: Παρ Σεπ 09, 2016 8:59 am

Re: Καλή προσέγγιση

#2

Μη αναγνωσμένη δημοσίευση από Ratio » Παρ Νοέμ 15, 2019 9:26 am

2019-11-15.png
2019-11-15.png (357.61 KiB) Προβλήθηκε 78 φορές
Θεωρούμε f(x)=x+lnx-e^2 , με x>0
για την οποία ισχύουν τα ακόλουθα:

\lim_{x\to 0^{+}}f(x)=-\infty
\\ \lim_{x\to \infty}f(x)=+\infty

και

\\ x_{1}<x_{2} \Leftrightarrow f(x_{1})<f(x_{2})

Η προσέγγιση ρίζας γίνεται μέσω θεωρήματος Bolzano , με τον κανόνα της διχοτόμησης του διαστήματος

1ο διάστημα: (1,e^2)
1η επαναληψη: επιλογή ανάμεσα στα διαστήματα (1,\frac{1+e^2}{2}) και  (\frac{1+e^2}{2},2) με εφαρμογή u. Bolzano
κ.ο.κ
Για ευκολία σε όσους μαθητές το επιχειρήσουν ένα απλό πρόγραμμα σε ψευδογλώσσα για να δουν την προσέγγιση. Η προσεγγιστική ρίζα ζητήθηκε με διαφορά 0.01


πρόγραμμα προσέγγιση

ΣΤΑΘΕΡΕΣ
e=-Ε(1)
r=2^2.5
k=2^2.5-2.5*ΛΟΓ(2)-Ε(2)
difference=0.01

ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: a,b,x,y1,y2,y3
ΑΚΕΡΑΙΕΣ: n
ΑΡΧΗ
a <-- 1
b <-- Ε(2)

n <-- 1
ΓΡΑΨΕ 'ακρο διαστηματος a = ', a
ΓΡΑΨΕ 'ακρο διαστηματος b = ', b
y1 <-- a+ΛΟΓ(a)-Ε(2)
y2 <-- b+ΛΟΓ(b)-Ε(2)
ΑΝ y1*y2<0 ΤΟΤΕ
x <-- (a+b)/2
y3 <-- x+ΛΟΓ(x)-Ε(2)
ΤΕΛΟΣ_ΑΝ
ΑΝ y1*y3<0 ΤΟΤΕ
b <-- (a+b)/2
ΑΛΛΙΩΣ_ΑΝ y2*y3<0 ΤΟΤΕ
a <-- (a+b)/2
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ '(',a,',',b,')-->(',y1,',',y2,')'

ΓΡΑΨΕ 'x=(a+b)/2=',x,' and f(x)= ',y3


ΓΡΑΨΕ 'διαφορα προσεγγισεων =', (a+b)/2 -r

ΓΡΑΨΕ 'διαφορά f(x)-k= ', Α_Τ(y3-k)
ΟΣΟ Α_Τ(x-r)>difference ΕΠΑΝΑΛΑΒΕ


y1 <-- a+ΛΟΓ(a)-Ε(2)
y2 <-- b+ΛΟΓ(b)-Ε(2)
ΑΝ y1*y2<0 ΤΟΤΕ
x <-- (a+b)/2
y3 <-- x+ΛΟΓ(x)-Ε(2)
ΤΕΛΟΣ_ΑΝ
ΑΝ y1*y3<0 ΤΟΤΕ
b <-- (a+b)/2
ΑΛΛΙΩΣ_ΑΝ y2*y3<0 ΤΟΤΕ
a <-- (a+b)/2
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ '(',a,',',b,')-->(',y1,',',y2,')'

ΓΡΑΨΕ 'x=(a+b)/2=',x,' and f(x)= ',y3


ΓΡΑΨΕ 'διαφορα προσεγγισεων =', (a+b)/2 -r

ΓΡΑΨΕ 'διαφορά f(x)-k= ', Α_Τ(y3-k)

n <-- n+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ 'number of repetitions=' , n

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Απάντηση

Επιστροφή σε “Διασκεδαστικά Μαθηματικά”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: kkala και 2 επισκέπτες